openssl Vulnerability Advisory Catalog

Total 262 security vulnerabilities recorded for openssl software and firmware.

← Back to All Vendors
Component: openssl

Issue summary: When CMS password-based decryption (RFC 3211 / PWRI key unwrap) processes attacker-supplied CMS data, an attacker-chosen stream-mode KE...

📅 2026-06-09
CVSS 7.5 Dossier →
Component: openssl

Issue summary: A signed integer overflow when sizing the destination buffer for Unicode output in ASN1_mbstring_ncopy() can lead to a heap buffer over...

📅 2026-06-09
CVSS 8.1 Dossier →
Component: openssl

Issue summary: A specially crafted PKCS#7 or S/MIME signed message could trigger a use-after-free during PKCS#7 signature verification. Impact summar...

📅 2026-06-09
CVSS 8.8 Dossier →
Component: openssl

Issue summary: The implementations of AES-SIV (RFC 5297) and AES-GCM-SIV (RFC 8452) mishandle the authentication of AAD (Additional Authenticated Data...

📅 2026-06-09
CVSS 4.8 Dossier →
Component: openssl

Issue summary: When an application drives an AES-OCB context through the public EVP_Cipher() one-shot interface, the application-supplied initialisati...

📅 2026-06-09
CVSS 7.5 Dossier →
Component: openssl

Issue summary: When the X509_VERIFY_PARAM_set1_email is called by an application to validate a crafted e-mail address, such as during S/MIME message v...

📅 2026-06-09
CVSS 6.2 Dossier →
Component: openssl

Issue summary: When EVP_PKEY_derive_set_peer() is called with a DHX (X9.42) peer key, the peer key is not properly checked for the subgroup membership...

📅 2026-06-09
CVSS 3.7 Dossier →
Component: openssl

Issue Summary: An error in the callback used to verify the certificate provided in a Root CA key update Certificate Management Protocol (CMP) message ...

📅 2026-06-09
CVSS 5.3 Dossier →
Component: openssl

Issue summary: The CMS_decrypt and PKCS7_decrypt functions are vulnerable to Bleichenbacher-style attack when an attacker is able to provide the CMS o...

📅 2026-06-09
CVSS 3.7 Dossier →
Component: openssl

Issue summary: An attacker-controlled CMP (Certificate Management Protocol) server could trigger a NULL pointer dereference in a CMP client applicatio...

📅 2026-06-09
CVSS 5.9 Dossier →
Component: openssl

Issue summary: A specially crafted password-encrypted CMS message can trigger a NULL pointer dereference during CMS decryption. Impact summary: This ...

📅 2026-06-09
CVSS 5.9 Dossier →
Component: openssl

Issue summary: When a partial-chain certificate verification is enabled together with OCSP response checking for the whole chain, a NULL dereference w...

📅 2026-06-09
CVSS 7.5 Dossier →
Component: openssl

Issue summary: Receiving a QUIC initial packet with an invalid token may trigger a NULL pointer dereference in the OpenSSL QUIC server with address va...

📅 2026-06-09
CVSS 7.5 Dossier →
Component: openssl

Issue summary: A malicious server can exploit TLS OCSP stapling by delivering a crafted response through the status_request extension, triggering a do...

📅 2026-06-09
CVSS 5.0 Dossier →
Component: openssl

Issue summary: Remote peer may exhaust heap memory of the QUIC server or client by flooding it with packets containing PATH_CHALLENGE frames. Impact ...

📅 2026-06-09
CVSS 7.5 Dossier →
CVE-2026-34182 CRITICAL
Component: openssl

Issue Summary: Cryptographic Message Services (CMS) processing fails to perform sufficient input validation on the cipher and tag length fields of Aut...

📅 2026-06-09
CVSS 9.1 Dossier →
Component: openssl

Issue Summary: The PKCS#12 file processing fails to perform sufficient input validation for files that use Password-Based Message Authentication Code ...

📅 2026-06-09
CVSS 7.4 Dossier →
Component: openssl

Issue summary: Parsing a crafted DER-encoded ASN.1 structure with a primitive element whose content exceeds 2 gigabytes in length may cause a heap buf...

📅 2026-06-09
CVSS 7.5 Dossier →
Component: openssl

Issue summary: Applications using RSASVE key encapsulation to establish a secret encryption key can send contents of an uninitialized memory buffer to...

📅 2026-04-07
CVSS 7.5 Dossier →
CVE-2026-31789 CRITICAL
Component: openssl

Issue summary: Converting an excessively large OCTET STRING value to a hexadecimal string leads to a heap buffer overflow on 32 bit platforms. Impact...

📅 2026-04-07
CVSS 9.8 Dossier →
Component: openssl

Issue summary: During processing of a crafted CMS EnvelopedData message with KeyTransportRecipientInfo a NULL pointer dereference can happen. Impact ...

📅 2026-04-07
CVSS 7.5 Dossier →
Component: openssl

Issue summary: During processing of a crafted CMS EnvelopedData message with KeyAgreeRecipientInfo a NULL pointer dereference can happen. Impact summ...

📅 2026-04-07
CVSS 7.5 Dossier →
Component: openssl

Issue summary: When a delta CRL that contains a Delta CRL Indicator extension is processed a NULL pointer dereference might happen if the required CRL...

📅 2026-04-07
CVSS 7.5 Dossier →
Component: openssl

Issue summary: An uncommon configuration of clients performing DANE TLSA-based server authentication, when paired with uncommon server DANE TLSA recor...

📅 2026-04-07
CVSS 8.1 Dossier →
Page 1 of 11 (262 Total Records)